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TRAINING FRAME CREATION

LET’S DEFINE OUR OWN FRAME 
AND SIMULATE IT
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TRAINING PCM FRAME DEFINITION:

Common Word Length:  16 bits

Words per Minor frame:  249

Bit Order:  MSB First

Frame Sync Location:  Leading

Subframe Mode:  SFID

Minor Frame Count Direction:  UP

First Minor Frame Number:  0

Number of Minor Frames:  100

SFID Word Number:  3

SFID MSB:  6

Frame Sync Pattern:  0xFE6B2840

Simulator & Bit Sync Information

Bit Rate 2.369 Mbps

Input Code:  NRZL
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Click the ‘S’  Button to 

bring up the LS-50P2 

Control

Select  File>Recall, then

Double-Click DEMO.SCS

To load a default DEMO 

PCM Setup
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Load the DEMO.SCS 

and enter format info 

from previous slide

Click the Value and then to Edit, then 

update and Click OK

Some Entries will toggle through valid 

settings

Common Word Length:  16 bits

Words per Minor frame:  249

Bit Order:  MSB First

Frame Sync Location:  Leading

Data Polarity:  NORMAL

Clock Polarity:  NORMAL

Subframe Mode:  SFID

Minor Frame Count Direction:  UP

First Minor Frame Number:  0

Number of Minor Frames:  100

SFID Word Number:  3

SFID MSB: 14
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Frame Sync Length:  32 bits

Frame Sync Pattern:  0xFE6B2840

Data Source: Simulator

Click the Load All button

Click the Value and then to Edit, then 

update and Click OK

Some Entries will toggle through valid 

settings
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Fill in the new Simulation format:

Ensure Track Decom is Checked

Fill in the Dynamic Words as shown:

Fill in the Unique Words as shown:

Bit Rate 2.369E6 Mbps

Input Code:  NRZL

Track Decom CheckBox must be checked

Then click the Load Simulator button
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Bit Rate:  2.369E6 Mbps

Using Right-Clicking  and fill in the new format:

Bit Sync  information

Bit Rate 1.1 Mbps

Input Source: SIMULATOR (J1-9)

Input Code:  NRZL

Then click the Load All Button

.

Note:  The asterisk 

‘*’ indicates that this 

configuration hasn’t 

been save yet



Select the TRAINING.SCS configuration file:

Click the Open Button.

Select the Simulator Tab, then Click the Start

Button to Start the Simulator.

You should now see Major and Minor Frame Locks
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Save the new PCM format:

From the Stream 1 Control Window select:

File>Save As:

Type TRAINING.SCS in the File Name 

TextBox,

Then Click SAVE

Next, Recall the TRAINING.SCS file just 

saved. Go to the L\S-50-P2 (Stream1) Setup  

and select:

File>Recall:
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From the above numbers, we get 594.6/60 = 9.91 -> 11.

From the Decom Tab, set Frames Per Interrupt to 11, 

Display the LS50P2 CVT by Clicking the

Button  on the Ls50P2 Control:

Tim eTag Frame Sync SFID Data

We find that configuring for a Frame Rate of <=60Hz optimal for 

all OSs.  The Rule of thumb is to divide the Minor Frame Rate

by 60 and round up to the next odd number.



Click the Load All Button

then Files>Save AS to TRAINING.SCS
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Tim eTag Frame Sync SFID Data

Now the FPI Rate should be below 60 Hz

We will make a new Parameter Database (PDB) for this PCM Format.  To do this we will start with the supplied DEMO.PRJ

which already has parameters defined in LDPS_10x_Training_Lesson-1.pdf.  
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From the LDPS Server

Control Banner, Select 

Editors>Project:

From the Edit PCM PDBASE 

Banner, Select: New

In the PDM Frame Information Window, 

Click the Import Button, 

Then Select and 

Open TRAINING.SCS.

From the Edit PCM PDBASE Banner 

Select Edit Dbase:

From the Edit PCM Database Banner, 

select Tools>Auto Generate:

Set the value to 1:.

Click OK

Click Generate IT
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This has filled the 

Pdatabase with basic 

parameters
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From the EDIT PCM PDBASE Banner Select 

File>Save As

Type:  TRAINING.PDB

Then Click OK.
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In the Server Banner, select:  Editors>Project

Right-Click in the Serial Data Stream Cards

Section for Card 1:  Select Add Card> LS50 P2

Open TRAINING.SCS

Open TRAINING.PBIN

From the PROJECT SETUP Banner, Select 

File>Save As:

TRAINING.PRJ
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At this point, you have enough information to record 

your basic PCM stream using the onboard Simulator 

and you can even replay the data:

From the Server select Project>Load: TRAINING.PRJ

You can now Click Record Button to archive some of 

the simulated data.

The Data Space Remaining display will decrease with 

time

Click the Record button again to stop recording.  

Close the Loaded Project from the Server 

Project>Close
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Put the Server in the Playback mode:

Select:  System>Mode>Playback

Select TRAINING_11038_2106_11038_2106 

will differ, then Click OPEN: 

Double-click TRAINING.PRJ

Click the Open Button

Click the Loop Button

To display the Major Frame Buffer (CVT) Click the 

Button
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Click Flush Buffer to clear out stale data

Click the Play Button on the Server Control

You will see data playing though the Serial Data Frame 

Buffer.

You can Loop, Stop, Reverse & Stop the data.

You can Slow it down, speed it up, move through the 

data with the Scroll control.

You can search for a time in the data, etc.
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In the Server Banner, select:  Edit>PDBase Ch4 (PCM)

Recall the Training database

Select File>Recall, 

Select: TRAINING.PBIN

Click the Open Button

Click Edit DBase



On the EDIT PCM Database Window, 

Starting with the definition of FS

Right-Click in FR0WD1 and Select:

Edit Word FR0WD1

Variable Name FS

Description BARKER CODE

Type (Size) INT_U (32 bits)

Bias 0.000000E+00

Scale 1.000000E+00

Scale Units

Frame Start 0

Frame Interval 1

Word Start 1

Word Interval 0

Starting Bit 15
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Variable Name FS

Description BARKER CODE

Type (Size) INT_U (32 bits)

Bias 0.000000E+00

Scale 1.000000E+00

Scale Units

Frame Start 0

Frame Interval 1

Word Start 1

Word Interval 0

Starting Bit 15
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This is a Prime Parameter

Right Click in the Subcom Info and the

Supercom Info area and verify the 

indicated values below:

Right-click in the 

Parameters Associated Block and 

Select New



Right-click in the appropriate areas and 

Add the information shown

When complete, Click Accept on both 

the Parameter Definition and the 

Edit PCM Word Windows

Note: Entering parameters larger

than 16 bits will show the screen below

Click Yes

Variable Name FS

Description BARKER CODE

Type (Size) INT_U (32 bits)

Bias 0.000000E+00

Scale 1.000000E+00

Scale Units

Frame Start 0

Frame Interval 1

Word Start 1

Word Interval 0

Starting Bit 15
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Enter the SFID definition:

Right-Click in FR0WD3 and Select:

Edit Word FR0WD3

Variable Name SFID

Description SUBFRAME ID

Type (Size) INT_U (8 bits)

Bias 0.000000E+00

Scale 1.000000E+00

Scale Units

Frame Start 0

Frame Interval 1

Word Start 3

Word Interval 0

Starting Bit 15      8
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This is another Prime Parameter

Right Click in the Subcom Info and the

Supercom Info area and verify the 

indicated values below:

Right-click in the 

Parameters Associated Block and 

Select New

Variable Name SFID

Description SUBFRAME ID

Type (Size) INT_U (8 bits)

Bias 0.000000E+00

Scale 1.000000E+00

Scale Units

Frame Start 0

Frame Interval 1

Word Start 3

Word Interval 0

Starting Bit 15      8
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Right-click in the appropriate areas and 

Add the information shown

When complete, Click Accept on both 

the Parameter Definition and the 

Edit PCM Word Windows

Variable Name SFID

Description SUBFRAME ID

Type (Size) INT_U (8 bits)

Bias 0.000000E+00

Scale 1.000000E+00

Scale Units

Frame Start 0

Frame Interval 1

Word Start 3

Word Interval 0

Starting Bit 15      8
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The definition of ALT_MSL is 

Subcommutated, Delete existing 

Prime word

Right - click on FR0WD5 and Select:

Delete Word FR0WD5

Click FR0WD6 then back to FR0WD5

Right - click on FR2WD5 and Select:

Add New Word

Variable Name ALT_MSL

Description ALTITUDE MSL

Type (Size) FLOAT (32 bits)

Bias 0.000000E+00

Scale 3.280840E+00

Scale Units FT

Frame Start 2

Frame Interval 0

Word Start 5

Word Interval 0

Starting Bit 15
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Right Click in the Subcom Info and

Supercom Info area set up the proper 

PCM Word values:

Now that we have proper commutation, 

we need to add our new parameter

Right-click in the 

Parameters Associated Block and 

Select New

Variable Name ALT_MSL

Description ALTITUDE MSL

Type (Size) FLOAT (32 bits)

Bias 0.000000E+00

Scale 3.280840E+00

Scale Units FT

Frame Start 2

Frame Interval 0

Word Start 5

Word Interval 0

Starting Bit 15



Right Click in the Subcom Info and

Supercom Info area and fill in the 

indicated values:

When complete, Click Accept on both 

the Parameter Definition and the 

Edit PCM Word Windows

Variable Name ALT_MSL

Description ALTITUDE MSL

Type (Size) FLOAT (32 bits)

Bias 0.000000E+00

Scale 3.280840E+00

Scale Units FT

Frame Start 2

Frame Interval 0

Word Start 5

Word Interval 0

Starting Bit 15
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The definition of GND_TRK

is Subcommutated, need to Delete 

existing Prime word FR0WD7.

Click FR0WD6 then FR0WD7.

Right - click on FR0WD7 and Select:

Delete Word FR0WD7

Right - click on FR3WD7 and Select:

Add New Word

Variable Name GND_TRK

Description GROUND TRACK ANGLE

Type (Size) FLOAT (32 bits)

Bias 0.000000E+00

Scale 5.729578E+01

Scale Units DEG

Frame Start 0

Frame Interval 4

Word Start 7

Word Interval 0

Starting Bit 15
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Variable Name GND_TRK

Description GROUND TRACK ANGLE

Type (Size) FLOAT (32 bits)

Bias 0.000000E+00

Scale 5.729578E+01

Scale Units DEG

Frame Start 1

Frame Interval 4

Word Start 7

Word Interval 0

Starting Bit 15
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Right Click in the Subcom Info and

Supercom Info area set up the proper 

PCM Word values:

Now that we have proper commutation, 

we need to add our new parameter

Right-click in the 

Parameters Associated Block and 

Select New



Variable Name GND_TRK

Description GROUND TRACK ANGLE

Type (Size) FLOAT (32 bits)

Bias 0.000000E+00

Scale 5.729578E+01

Scale Units DEG

Frame Start 1

Frame Interval 4

Word Start 7

Word Interval 0

Starting Bit 15
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Right Click in the Subcom Info and

Supercom Info area and fill in the 

indicated values:

When complete, Click Accept on both the 

Parameter Definition and the 

Edit PCM Word Windows



The definition of N12VDC is 

Subcommutated, Delete existing 

Prime word

Right - click on FR0WD9 and Select:

Delete Word FR0WD9

Click FR0WD10 then FR0WD9.

Right - click on FR0WD9 and Select:

Add New Word
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Right Click in the Subcom Info and

Supercom Info area set up the proper 

PCM Word values:

Now that we have proper commutation, 

we need to add our new parameter

Right-click in the 

Parameters Associated Block and 

Select New
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Right Click in the Subcom Info and

Supercom Info area and fill in the 

indicated values:

When complete, Click Accept on both 

the Parameter Definition and Edit 

PCM Definition Form.

Variable Name N12VDC

Description -12VDC

Type (Size) INT_U (8 bits)

Bias 0.0000000E+00

Scale 1.1110000E-01

Scale Units VOLT

Frame Start 2

Frame Interval 0

Word Start 9

Word Interval 0

Starting Bit 7       0



The definition of P12VDC is 

Subcommutated.

Right - click on FR1WD9 and Select:

Add New Word

LDPS_10x
Populating The Training .PDB 17

36



LDPS_10x
Populating The Training .PDB 18

37

Right Click in the Subcom Info and

Supercom Info area set up the proper 

PCM Word values:

Right-click in the Parameters 

Associated Block and Select New



Right Click in the Subcom Info and

Supercom Info area and fill in the 

indicated values:

When complete, Click Accept on both 

the Parameter Definition and Edit 

PCM Definition Form.
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Clock OK
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You can add a comment in this Field

Select File>Save

This saves the Updated 

TRAINING.PBIN and TRAINING.PDB.

This updated .PBIN will be called by 

your previous TRAINING.PRJ Project.

Note:  The .PDB file is a Human 

Readable version of the .PBIN binary

File.  With a bit of effort you can import 

this Text file into EXCEL using Tab 

delimitation

Close the EDITPCMDATABSE 

application by clicking the

Button.
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Load the TRAINING.PRJ using the 

Server Selecting Project>Load

On the Client Click the              Button

Display>New Page 

Right – click in the Page and Select

Add Widget>Text Type>Alpha 

Numeric
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Right – click in the AlphaNumList and 

Select Properties

Click the           Button 

This brings up the Param Info List
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You populate your Widget finding your 

parameter possibly using the Search

Windows, then left-click the parameter 

(a circle with a slash indicates you have 

selected the parameter and may drag it 

to the Widget Parameter Name

CheckBox).  My choice is FS.

Cick in the Parameter Label

TextBox to change the Widget Label

Select the type of Display Radix

and Value Width

Finish by clicking the Accept Button



LDPS_10x
Make a Test Display Page 4

44

Hover your cursor in the Banner of the 

Display Page to access its Options

Click the Save As Button to save this 

new Display Page

Enter the name, Training for this new 

Display Page

Click the Save Futton

To save this new 

Display Page

Close the Display Page by 

Clicking the          Button 

From the LDPS_10x Banner close 

currently loaded Training.PRJ by 

selecting in the Banner

Project>Close
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Open the Project Editor,

Recall the TRAINING.PRJ

Left-click in the Display Page area and 

steer to the recently saved 

TRAINING.DPY

Select:  File>Save

Now when you load the Training 

Project you will see the Training Display 

also  

Close the Project Setup application by 

Clicking the         Button 
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Load the TRAINING.PRJ for Test.

On the Ls50P2 Control, click the 

Button to bring up the Decom control 

windows.

Click the              Button.

Stop the Simulator by Clicking the 

Button.

Notice the display indicates Stale Data:

Restart the Simulator by Clicking the

Button. 
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Since the Simulated on-boad LS-50P2 

Simulator has inherited the DEMO 

simulations, you can load the 

DemoSet.DPS and see how those 

Display Pages and Widgets are 

configured.

On the LDPS_10x Client click the  

Button and load the 

DemoSet.DPS.

You can click through the Tabs to see 

each DEMO display.

The demo_postlaunch.DPY Tab 

includes a Sample Based Strip Chart

Refer to the Training document:

LDPS_10x_Training_Lesson-1.pdf to 

understand the DEMO.PRJ Displays, 

etc.
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You can copy any of these DEMO

Display Widgets by right-clicking in the 

Widget to copy and selecting the 

Copy To Clipboard option

Select the Training Display. Place the 

cursor to where you want the Widget 

placed. Right-click 

And select the

Paste Clipboard

To paste the

Widget.

Save the updated 

TRAINING.DPY.

The next time you load TRAINING.PRJ,

The Strip Chart will be included.
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IT IS LEFT FOR THE CLASS TO COMPLETE 
THE REST OF THE TRAINING FRAME 

DISPLAYS


